URI: 
       libbitcoin-system-9999.ebuild - parlay - yet another gentoo overlay
  HTML git clone https://git.parazyd.org/parlay
   DIR Log
   DIR Files
   DIR Refs
   DIR README
       ---
       libbitcoin-system-9999.ebuild (968B)
       ---
            1 # Copyright 1999-2022 Gentoo Authors
            2 # Distributed under the terms of the GNU General Public License v2
            3 
            4 EAPI=8
            5 
            6 inherit autotools git-r3
            7 
            8 DESCRIPTION="The Bitcoin Development Library"
            9 HOMEPAGE="https://libbitcoin.info"
           10 EGIT_REPO_URI="https://github.com/libbitcoin/${PN}"
           11 
           12 LICENSE="AGPL-3+"
           13 SLOT="0"
           14 KEYWORDS="~amd64 ~x86"
           15 IUSE="static-libs debug +icu test +doc +png"
           16 
           17 DEPEND="
           18         png? (
           19                 >=media-libs/libpng-1.6.37:=
           20                 >=media-gfx/qrencode-3.4.4:=
           21         )
           22         icu? (
           23                 >=dev-libs/icu-51.2:=
           24                 >=dev-libs/boost-1.72.0:=[threads(+),icu(+)]
           25         )
           26         >=dev-libs/boost-1.72.0:=[threads(+)]
           27         >dev-libs/libsecp256k1-0.1_pre20200911:=[recovery,schnorr]
           28 "
           29 RDEPEND="${DEPEND}"
           30 
           31 PATCHES=( "${FILESDIR}/libsecp256k1-relax.patch" )
           32 
           33 src_prepare() {
           34         default
           35         eautoreconf
           36 }
           37 
           38 src_configure() {
           39         econf \
           40                 $(use_with icu) \
           41                 $(use_with test tests) \
           42                 $(use_with doc examples) \
           43                 $(use_with png) \
           44                 $(use_with png qrencode) \
           45                 $(use_enable static-libs static) \
           46                 $(use_enable debug ndebug)
           47 }